blob: 9a8be15daba4c0054ec65e58f6b02f752f87a442 [file] [log] [blame]
Andrew Geissler20137392023-10-12 04:59:14 -06001SUMMARY = "Start the program if the specified terminal device is available."
2DESCRIPTION = "ttyrun is typically used to prevent a respawn through the \
3init(8) program when a terminal is not available."
4HOMEPAGE = "https://github.com/ibm-s390-linux/s390-tools"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=f5118f167b055bfd7c3450803f1847af"
8
9SRC_URI = "git://github.com/ibm-s390-linux/s390-tools;protocol=https;branch=master"
Patrick Williams44b3caf2024-04-12 16:51:14 -050010SRCREV = "9eea78b3ad8ab3710fb3b2d80b9cd058d7c8aba7"
Andrew Geissler20137392023-10-12 04:59:14 -060011
12S = "${WORKDIR}/git"
13
14EXTRA_OEMAKE = "\
15 V=1 \
16 CC="${CC}" \
17 DISTRELEASE=${PR} \
18 "
19
20# We just want ttyrun and not the rest of s390-utils
21
22do_configure() {
23 oe_runmake -C ${S}/iucvterm/src clean
24}
25
26do_compile() {
27 oe_runmake -C ${S}/iucvterm/src ttyrun
28}
29
30do_install() {
31 install -d ${D}${sbindir}
32 install ${S}/iucvterm/src/ttyrun ${D}${sbindir}
33}