blob: 07638d7ad789cf3cf5fb307ad013683990ea3a71 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001inherit setuptools3
2require python-cython.inc
3
4RDEPENDS:${PN} += "\
5 python3-setuptools \
6"
7
8# running build_ext a second time during install fails, because Python
9# would then attempt to import cythonized modules built for the target
10# architecture.
11SETUPTOOLS_INSTALL_ARGS += "--skip-build"
12
13do_install:append() {
14 # rename scripts that would conflict with the Python 2 build of Cython
15 mv ${D}${bindir}/cython ${D}${bindir}/cython3
16 mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3
17 mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3
18}
19
Andrew Geissler517393d2023-01-13 08:55:19 -060020PACKAGESPLITFUNCS =+ "cython_fix_sources"
Andrew Geissler595f6302022-01-24 19:11:47 +000021
22cython_fix_sources () {
Patrick Williamsac13d5f2023-11-24 18:59:46 -060023 for f in ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Compiler/FlowControl.c \
24 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Compiler/FusedNode.c \
25 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Compiler/Scanning.c \
26 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Compiler/Visitor.c \
27 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Plex/Actions.c \
28 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Plex/Scanners.c \
29 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Runtime/refnanny.c \
30 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Tempita/_tempita.c \
Andrew Geissler595f6302022-01-24 19:11:47 +000031 ${PKGD}${libdir}/${PYTHON_DIR}/site-packages/Cython*/SOURCES.txt; do
32 if [ -e $f ]; then
Patrick Williamsac13d5f2023-11-24 18:59:46 -060033 sed -i -e 's#${WORKDIR}/Cython-${PV}#${TARGET_DBGSRC_DIR}#g' $f
Andrew Geissler595f6302022-01-24 19:11:47 +000034 fi
35 done
36}
37