blob: e714ad838e9541976e1050310afd7548d7fbb5ed [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Simple Python wrapper around the OpenSSL library"
2HOMEPAGE = "https://pyopenssl.org/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
Patrick Williams73bd93f2024-02-20 08:07:48 -06006DEPENDS += "openssl python3-cryptography"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06007
Patrick Williams44b3caf2024-04-12 16:51:14 -05008SRC_URI[sha256sum] = "cabed4bfaa5df9f1a16c0ef64a0cb65318b5cd077a7eda7d6970131ca2f41a6f"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06009
10PYPI_PACKAGE = "pyOpenSSL"
11inherit pypi setuptools3
12
13PACKAGES =+ "${PN}-tests"
14FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
15
16RDEPENDS:${PN}:class-target = " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060017 python3-cryptography \
18 python3-six \
19 python3-threading \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060020"
21RDEPENDS:${PN}-tests = "${PN}"
22
23BBCLASSEXTEND = "native nativesdk"