blob: 90e3599d32437e68b2733dbc386d3955e7a6e269 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
2DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
3OS-independent reference implementation of the Advanced Configuration and \
4Power Interface Specification (ACPI). ACPICA code contains those portions of \
5ACPI meant to be directly integrated into the host OS as a kernel-resident \
6subsystem, and a small set of tools to assist in developing and debugging \
7ACPI tables."
8
Patrick Williams2a254922023-08-11 09:48:11 -05009HOMEPAGE = "https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/overview.html"
Andrew Geissler595f6302022-01-24 19:11:47 +000010SECTION = "console/tools"
11
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000012LICENSE = "Intel | BSD-3-Clause | GPL-2.0-only"
Patrick Williams44b3caf2024-04-12 16:51:14 -050013LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=05eb845b15a27440410f456adc2ed082"
Andrew Geissler595f6302022-01-24 19:11:47 +000014
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17DEPENDS = "m4-native flex-native bison-native"
18
Patrick Williams44b3caf2024-04-12 16:51:14 -050019SRC_URI = "git://github.com/acpica/acpica;protocol=https;branch=master"
20SRCREV = "170fc3076a86777077637f10b05c32ac21ac13aa"
Andrew Geissler595f6302022-01-24 19:11:47 +000021
Patrick Williams44b3caf2024-04-12 16:51:14 -050022S = "${WORKDIR}/git"
Andrew Geissler595f6302022-01-24 19:11:47 +000023
24inherit update-alternatives
25
26ALTERNATIVE_PRIORITY = "100"
27ALTERNATIVE:${PN} = "acpixtract acpidump"
28
29EXTRA_OEMAKE = "CC='${CC}' \
30 OPT_CFLAGS=-Wall \
31 DESTDIR=${D} \
32 PREFIX=${prefix} \
33 INSTALLDIR=${bindir} \
34 INSTALLFLAGS= \
35 YACC=bison \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060036 YFLAGS='-y --file-prefix-map=${WORKDIR}=${TARGET_DBGSRC_DIR}' \
Andrew Geissler595f6302022-01-24 19:11:47 +000037 "
38
39do_install() {
40 oe_runmake install
41}
42
43# iasl*.bb is a subset of this recipe, so RREPLACE it
44PROVIDES = "iasl"
45RPROVIDES:${PN} += "iasl"
46RREPLACES:${PN} += "iasl"
47RCONFLICTS:${PN} += "iasl"
48
Patrick Williamsac13d5f2023-11-24 18:59:46 -060049BBCLASSEXTEND = "native nativesdk"