blob: 70a3f82540cd45d6864b445668f293a127b2d167 [file] [log] [blame]
Matt Spinlerf7d548b2017-03-21 15:02:13 -05001SUMMARY = "Generate fan presence YAML from the MRW"
2PR = "r1"
Brad Bishop75f03872018-11-03 09:41:57 -07003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Matt Spinlerf7d548b2017-03-21 15:02:13 -05005
6inherit native
Brad Bishopbd9931f2017-04-22 16:26:22 -04007inherit phosphor-fan
Matt Spinler0a8ea632017-12-14 13:31:55 -06008inherit mrw-xml
Matt Spinlerf7d548b2017-03-21 15:02:13 -05009
10DEPENDS += " \
11 mrw-native \
12 mrw-perl-tools-native \
13 "
14
15PROVIDES += "virtual/phosphor-fan-presence-config"
16
17S = "${WORKDIR}"
18
19do_install() {
20 DEST=${D}${presence_datadir}
21 install -d ${DEST}
22
23 ${bindir}/perl-native/perl \
24 ${bindir}/gen_presence_yaml.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060025 -i ${mrw_datadir}/${MRW_XML} \
Matt Spinlerf7d548b2017-03-21 15:02:13 -050026 -o ${DEST}/config.yaml
27}