Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | require libpcap.inc |
| 2 | |
| 3 | SRC_URI += " \ |
| 4 | file://libpcap-pkgconfig-support.patch \ |
| 5 | file://0001-Fix-compiler_state_t.ai-usage-when-INET6-is-not-defi.patch \ |
| 6 | file://0002-Add-missing-compiler_state_t-parameter.patch \ |
| 7 | file://disable-remote.patch \ |
| 8 | file://fix-grammar-deps.patch \ |
| 9 | " |
| 10 | |
| 11 | SRC_URI[md5sum] = "3d48f9cd171ff12b0efd9134b52f1447" |
| 12 | SRC_URI[sha256sum] = "673dbc69fdc3f5a86fb5759ab19899039a8e5e6c631749e48dcd9c6f0c83541e" |
| 13 | |
| 14 | # |
| 15 | # make install doesn't cover the shared lib |
| 16 | # make install-shared is just broken (no symlinks) |
| 17 | # |
| 18 | |
| 19 | do_configure_prepend () { |
| 20 | #remove hardcoded references to /usr/include |
| 21 | sed 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i ${S}/configure.ac |
| 22 | } |
| 23 | |
| 24 | do_install_prepend () { |
| 25 | install -d ${D}${libdir} |
| 26 | install -d ${D}${bindir} |
| 27 | oe_runmake install-shared DESTDIR=${D} |
| 28 | oe_libinstall -a -so libpcap ${D}${libdir} |
| 29 | sed "s|@VERSION@|${PV}|" -i ${B}/libpcap.pc |
| 30 | install -D -m 0644 libpcap.pc ${D}${libdir}/pkgconfig/libpcap.pc |
| 31 | } |