blob: e61b00efa425ada6953a2a82a6db39dafb5fc1b2 [file] [log] [blame]
Patrick Williams45852732022-04-02 08:58:32 -05001DESCRIPTION = "Python3 interface to the wxWidgets Cross-platform C++ GUI toolkit."
2HOMEPAGE = "http://www.wxpython.org"
3
4LICENSE = "WXwindows"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce1d18e2d633d41786c0a8dfbc80917"
6
7DEPENDS = "wxwidgets-native wxwidgets"
8
9PYPI_PACKAGE = "wxPython"
10
11SRC_URI += "file://add-back-option-build-base.patch \
12 file://wxgtk-fixup-build-scripts.patch \
13 file://sip-fix-override-functions.patch \
14 "
15SRC_URI[sha256sum] = "00e5e3180ac7f2852f342ad341d57c44e7e4326de0b550b9a5c4a8361b6c3528"
16
17S = "${WORKDIR}/wxPython-${PV}"
18
19inherit pypi setuptools3 pkgconfig
20
21export WX_CONFIG = "'${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config --prefix=${STAGING_EXECPREFIXDIR}'"
22
23RDEPENDS:${PN} = "\
24 python3-difflib \
25 python3-image \
26 python3-numpy \
27 python3-pillow \
28 python3-pprint \
29 python3-pycairo \
30 python3-six \
31 python3-xml \
32"