blob: 6211efa7149adb8e1cd0587dbabf19967e1c5576 [file] [log] [blame]
Brad Bishop7cce0f22017-01-17 09:21:15 -05001SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
2DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
Chris Austen9d3325a2015-10-24 19:34:11 -05003PR = "r1"
4
Matthew Barthe6d12952016-09-28 09:51:58 -05005inherit autotools pkgconfig
Chris Austen9d3325a2015-10-24 19:34:11 -05006inherit obmc-phosphor-license
Tom Josephdcdc8ea2017-02-01 19:47:27 +05307inherit obmc-phosphor-ipmiprovider-symlink
8inherit obmc-phosphor-utils
Tom Joseph464b90a2017-10-17 22:52:49 +05309inherit pythonnative
10
11require ${PN}.inc
Chris Austen9d3325a2015-10-24 19:34:11 -050012
Brad Bishopceb1c9a2017-01-17 10:07:14 -050013DEPENDS += "phosphor-ipmi-host"
Matthew Barthe6d12952016-09-28 09:51:58 -050014DEPENDS += "autoconf-archive-native"
Patrick Williams04f099a2017-08-17 10:42:32 -050015DEPENDS += "sdbusplus sdbusplus-native"
16DEPENDS += "phosphor-logging"
17DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
18DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
Tom Joseph464b90a2017-10-17 22:52:49 +053019DEPENDS += "sdbus++-native"
Patrick Williams04f099a2017-08-17 10:42:32 -050020
21RDEPENDS_${PN} += " \
22 sdbusplus \
23 phosphor-logging \
24 openpower-dbus-interfaces \
25 phosphor-dbus-interfaces \
26 "
Matthew Barthe6d12952016-09-28 09:51:58 -050027
Chris Austenf6d294d2016-01-23 18:00:11 -060028TARGET_CFLAGS += "-fpic"
Chris Austen9d3325a2015-10-24 19:34:11 -050029
Tom Josephdcdc8ea2017-02-01 19:47:27 +053030HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
31
Chris Austen9d3325a2015-10-24 19:34:11 -050032S = "${WORKDIR}/git"
33
Tom Josephdcdc8ea2017-02-01 19:47:27 +053034FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Matthew Barthe6d12952016-09-28 09:51:58 -050035FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Tom Josephdcdc8ea2017-02-01 19:47:27 +053036FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"