Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU cpio is a program to manage archives of files" |
| 2 | DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \ |
| 3 | another. It handles a number of cpio formats as well as reading and writing tar files." |
| 4 | HOMEPAGE = "http://www.gnu.org/software/cpio/" |
| 5 | SECTION = "base" |
| 6 | LICENSE = "GPLv3" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \ |
| 10 | file://0001-Unset-need_charset_alias-when-building-for-musl.patch \ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 11 | file://0002-src-global.c-Remove-superfluous-declaration-of-progr.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "389c5452d667c23b5eceb206f5000810" |
| 15 | SRC_URI[sha256sum] = "e87470d9c984317f658567c03bfefb6b0c829ff17dbf6b0de48d71a4c8f3db88" |
| 16 | |
| 17 | inherit autotools gettext texinfo |
| 18 | |
| 19 | EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}" |
| 20 | |
| 21 | do_install () { |
| 22 | autotools_do_install |
| 23 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 24 | install -d ${D}${base_bindir}/ |
| 25 | mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio" |
| 26 | rmdir ${D}${bindir}/ |
| 27 | fi |
| 28 | |
| 29 | # Avoid conflicts with the version from tar |
| 30 | mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8" |
| 31 | } |
| 32 | |
| 33 | PACKAGES =+ "${PN}-rmt" |
| 34 | |
| 35 | FILES_${PN}-rmt = "${sbindir}/rmt*" |
| 36 | |
| 37 | inherit update-alternatives |
| 38 | |
| 39 | ALTERNATIVE_PRIORITY = "100" |
| 40 | |
| 41 | ALTERNATIVE_${PN} = "cpio" |
| 42 | ALTERNATIVE_${PN}-rmt = "rmt" |
| 43 | |
| 44 | ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio" |
| 45 | |
| 46 | ALTERNATIVE_PRIORITY[rmt] = "50" |
| 47 | ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt" |
| 48 | |
| 49 | BBCLASSEXTEND = "native" |