blob: 9e35a80f8b6dd793121a6b12c9814c98576ce9a2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNU cpio is a program to manage archives of files"
2DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \
3another. It handles a number of cpio formats as well as reading and writing tar files."
4HOMEPAGE = "http://www.gnu.org/software/cpio/"
5SECTION = "base"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
8
9SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \
10 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -050011 file://0002-src-global.c-Remove-superfluous-declaration-of-progr.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050012 "
13
14SRC_URI[md5sum] = "389c5452d667c23b5eceb206f5000810"
15SRC_URI[sha256sum] = "e87470d9c984317f658567c03bfefb6b0c829ff17dbf6b0de48d71a4c8f3db88"
16
17inherit autotools gettext texinfo
18
19EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
20
21do_install () {
22 autotools_do_install
23 if [ "${base_bindir}" != "${bindir}" ]; then
24 install -d ${D}${base_bindir}/
25 mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio"
26 rmdir ${D}${bindir}/
27 fi
28
29 # Avoid conflicts with the version from tar
30 mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8"
31}
32
33PACKAGES =+ "${PN}-rmt"
34
35FILES_${PN}-rmt = "${sbindir}/rmt*"
36
37inherit update-alternatives
38
39ALTERNATIVE_PRIORITY = "100"
40
41ALTERNATIVE_${PN} = "cpio"
42ALTERNATIVE_${PN}-rmt = "rmt"
43
44ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
45
46ALTERNATIVE_PRIORITY[rmt] = "50"
47ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
48
49BBCLASSEXTEND = "native"