blob: 3a2d8733e9602e87d92027e0becdf6c4d7133129 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Python interface to libarchive"
2DESCRIPTION = "A Python interface to libarchive. It uses the standard ctypes module to \
3 dynamically load and access the C library."
4HOMEPAGE = "https://github.com/Changaco/python-libarchive-c"
5LICENSE = "CC0-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=bcab380227a83bc147350b40a81e6ffc"
7
8PYPI_PACKAGE = "libarchive-c"
9
10inherit pypi setuptools3
11
12SRC_URI[md5sum] = "083bd2cb0043c1e22a52cb9a05e31532"
13SRC_URI[sha256sum] = "9919344cec203f5db6596a29b5bc26b07ba9662925a05e24980b84709232ef60"
14
Andrew Geissler475cb722020-07-10 16:00:51 -050015RDEPENDS_${PN} += "\
16 libarchive \
17 ${PYTHON_PN}-ctypes \
18 ${PYTHON_PN}-mmap \
19"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21BBCLASSEXTEND = "native"