blob: 3acc523a88493d9048ae9175d4b8b00ea0f0936d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Baremetal examples to work with the several QEMU architectures supported on OpenEmbedded"
2HOMEPAGE = "https://github.com/aehs29/baremetal-helloqemu"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=39346640a23c701e4f459e05f56f4449"
5
6SRCREV = "99f4fa4a3b266b42b52af302610b0f4f429ba5e3"
7PV = "0.1+git${SRCPV}"
8
9SRC_URI = "git://github.com/aehs29/baremetal-helloqemu.git;protocol=https;branch=master"
10
Andrew Geissler4873add2020-11-02 18:44:49 -060011S = "${WORKDIR}/git/"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
Andrew Geissler475cb722020-07-10 16:00:51 -050013# The following variables should be set to accomodate each application
14BAREMETAL_BINNAME ?= "hello_baremetal_${MACHINE}"
15IMAGE_LINK_NAME ?= "baremetal-helloworld-image-${MACHINE}"
16IMAGE_NAME_SUFFIX ?= ""
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
Andrew Geissler475cb722020-07-10 16:00:51 -050018# Baremetal-Image creates the proper wiring, assumes the output is provided in
19# binary and ELF format, installed on ${base_libdir}/firmware/ , we want a
20# package to be created since we might have some way of updating the baremetal
21# firmware from Linux
22inherit baremetal-image
23
24
25# These parameters are app specific for this example
Andrew Geissler82c905d2020-04-13 13:39:40 -050026# This will be translated automatically to the architecture and
27# machine that QEMU uses on OE, e.g. -machine virt -cpu cortex-a57
28# but the examples can also be run on other architectures/machines
29# such as vexpress-a15 by overriding the setting on the machine.conf
30COMPATIBLE_MACHINE = "qemuarmv5|qemuarm|qemuarm64"
31
32BAREMETAL_QEMUARCH ?= ""
33BAREMETAL_QEMUARCH_qemuarmv5 = "versatile"
34BAREMETAL_QEMUARCH_qemuarm = "arm"
35BAREMETAL_QEMUARCH_qemuarm64 = "aarch64"
36
Andrew Geissler82c905d2020-04-13 13:39:40 -050037EXTRA_OEMAKE_append = " QEMUARCH=${BAREMETAL_QEMUARCH} V=1"
38
Andrew Geissler475cb722020-07-10 16:00:51 -050039
40# Install binaries on the proper location for baremetal-image to fetch and deploy
Andrew Geissler82c905d2020-04-13 13:39:40 -050041do_install(){
Andrew Geissler475cb722020-07-10 16:00:51 -050042 install -d ${D}/${base_libdir}/firmware
43 install -m 755 ${B}build/hello_baremetal_${BAREMETAL_QEMUARCH}.bin ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin
44 install -m 755 ${B}build/hello_baremetal_${BAREMETAL_QEMUARCH}.elf ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf
Andrew Geissler82c905d2020-04-13 13:39:40 -050045}
46
47FILES_${PN} += " \
Andrew Geissler475cb722020-07-10 16:00:51 -050048 ${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin \
49 ${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf \
Andrew Geissler82c905d2020-04-13 13:39:40 -050050"