blob: aa4d8042cf85481fd41dbf30e13905fffc0e2df0 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Disk partition editing/resizing utility"
2HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c"
5SECTION = "console/tools"
6DEPENDS = "ncurses readline util-linux virtual/libiconv"
7
8SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
9 file://no_check.patch \
10 file://fix-doc-mandir.patch \
11 file://0002-libparted_fs_resize-link-against-libuuid-explicitly-.patch \
12 file://0001-Move-python-helper-scripts-used-only-in-tests-to-Pyt.patch \
13 file://run-ptest \
14 file://0001-libparted-fs-add-sourcedir-lib-to-include-paths.patch \
15 file://0002-tests-use-skip_-rather-than-skip_test_-which-is-unde.patch \
16 "
17
18SRC_URI[md5sum] = "090655d05f3c471aa8e15a27536889ec"
19SRC_URI[sha256sum] = "57e2b4bd87018625c515421d4524f6e3b55175b472302056391c5f7eccb83d44"
20
21EXTRA_OECONF = "--disable-device-mapper"
22
23inherit autotools pkgconfig gettext texinfo ptest
24
Andrew Geissler5a43b432020-06-13 10:46:56 -050025BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050026
27do_compile_ptest() {
28 oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize print-flags
29}
30
31do_install_ptest() {
32 t=${D}${PTEST_PATH}
33 mkdir $t/build-aux
34 cp ${S}/build-aux/test-driver $t/build-aux/
35 cp -r ${S}/tests $t
36 cp ${B}/tests/Makefile $t/tests/
37 sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile
38 sed -i "s|^srcdir =.*|srcdir = \.|g" $t/tests/Makefile
39 sed -i "s|^abs_srcdir =.*|abs_srcdir = \.|g" $t/tests/Makefile
40 sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = \.\.|g" $t/tests/Makefile
41 sed -i "s|^Makefile:.*|Makefile:|g" $t/tests/Makefile
42 for i in print-align print-max print-flags dup-clobber duplicate fs-resize; \
43 do cp ${B}/tests/.libs/$i $t/tests/; \
44 done
45 sed -e 's| ../parted||' -i $t/tests/*.sh
46}
47
48RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make gawk e2fsprogs-mke2fs"
Andrew Geissler4873add2020-11-02 18:44:49 -060049
Andrew Geissler82c905d2020-04-13 13:39:40 -050050RDEPENDS_${PN}-ptest_append_libc-glibc = "\
51 glibc-utils \
52 locale-base-en-us \
53 "
54
55inherit update-alternatives
56
57ALTERNATIVE_PRIORITY = "100"
58ALTERNATIVE_${PN} = "partprobe"
59ALTERNATIVE_LINK_NAME[partprobe] = "${sbindir}/partprobe"