blob: 2f8a8f8b28be832e89380f9b098edc9eb45d161d [file] [log] [blame]
Matt Spinler575b0c02018-03-28 12:59:43 -05001SUMMARY = "IBM enhanced error logging"
2DESCRIPTION = "Adds additional error logging functionality for IBM systems"
3PR = "r1"
Patrick Venture18823e62018-10-26 09:39:44 -07004PV = "1.0+git${SRCPV}"
Matt Spinler575b0c02018-03-28 12:59:43 -05005HOMEPAGE = "https://github.com/openbmc/ibm-logging"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8SRC_URI += "git://github.com/openbmc/ibm-logging"
Andrew Geissler497a23e2020-05-14 13:50:24 +00009SRCREV = "b9ba941618a08f30ed9ec9b23d33f3944c589a6f"
Matt Spinler575b0c02018-03-28 12:59:43 -050010
11inherit autotools
12inherit pkgconfig
Matt Spinler1a9ef192020-02-20 10:56:34 -060013inherit python3native
Matt Spinler575b0c02018-03-28 12:59:43 -050014inherit obmc-phosphor-dbus-service
15inherit obmc-phosphor-systemd
Matt Spinler17395012018-03-28 14:00:19 -050016inherit phosphor-dbus-yaml
Matt Spinler575b0c02018-03-28 12:59:43 -050017
18DEPENDS += " \
19 ibm-dbus-interfaces \
20 phosphor-logging \
21 nlohmann-json \
22 autoconf-archive-native \
23 sdbusplus \
24 "
25
Matt Spinler575b0c02018-03-28 12:59:43 -050026S = "${WORKDIR}/git"
27
28SRC_URI += "file://policyTable.json"
29
30PACKAGECONFIG ??= ""
31PACKAGECONFIG[policy-interface] = "--enable-policy-interface, --disable-policy-interface,,"
32
Brad Bishope1615142020-04-22 14:06:02 -040033PACKAGECONFIG_ibm-ac-server = "policy-interface"
34PACKAGECONFIG_mihawk = "policy-interface"
35
Matt Spinler575b0c02018-03-28 12:59:43 -050036SERVICE = "com.ibm.Logging.service"
37DBUS_SERVICE_${PN} += "${SERVICE}"
38
39#The link is so that this service will restart if phosphor-logging restarts.
40#The BindsTo in the service will not do the restart, it will only do the
41#original start and a stop.
42LOG_FMT = "../${SERVICE}:xyz.openbmc_project.Logging.service.wants/${SERVICE}"
43SYSTEMD_LINK_${PN} += "${LOG_FMT}"
44
45do_install_append(){
46
47 install -d ${D}${datadir}/ibm-logging
48
49 ${S}/condense_policy.py \
50 -p ${WORKDIR}/policyTable.json \
51 -c ${D}/${datadir}/ibm-logging/policy.json
52}
Matt Spinler17395012018-03-28 14:00:19 -050053
54#An optional task to generate a report on all of the errors
55#created by OpenBMC, and compare these errors to what is
56#in the error policy table
57do_report(){
58
59 ${S}/create_error_reports.py \
60 -p ${D}/${datadir}/ibm-logging/policy.json \
61 -y ${STAGING_DIR_NATIVE}${yaml_dir} \
62 -e ${WORKDIR}/build/all_errors.json \
63 -x ${WORKDIR}/build/policy_crosscheck.txt
64
65}
66
67addtask report
68
69#Collect all of the error YAML files into our recipe-sysroot-native dir.
70do_report[depends] = " \
71 ibm-logging:do_install \
72 phosphor-logging-error-logs-native:do_populate_sysroot \
73 phosphor-dbus-interfaces-native:do_populate_sysroot \
74 openpower-dbus-interfaces-native:do_populate_sysroot \
75 openpower-occ-control-native:do_populate_sysroot \
76 openpower-debug-collector-native:do_populate_sysroot \
77 "