blob: 129bb35bcc93921456dcbdc98eae9cd7d6fdf86d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "Google gRPC"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7DEPENDS += "${PYTHON_PN}-protobuf"
8
9SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
10SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \
11 file://riscv64_support.patch \
Andrew Geisslere231d582020-05-05 08:53:09 -050012 file://0001-Fix-build-on-riscv32.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013"
14SRC_URI[md5sum] = "ccaf4e7eb4f031d926fb80035d193b98"
15SRC_URI[sha256sum] = "a899725d34769a498ecd3be154021c4368dd22bdc69473f6ec46779696f626c4"
16
17RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \
18 ${PYTHON_PN}-setuptools \
19 ${PYTHON_PN}-six \
20"
21
22inherit setuptools3
23inherit pypi
24
25export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1"
26
27do_compile_prepend_toolchain-clang() {
28 export GRPC_PYTHON_CFLAGS='-fvisibility=hidden -fno-wrapv -fno-exceptions'
29}
30
31CLEANBROKEN = "1"
32
33BBCLASSEXTEND = "native nativesdk"
34
35CCACHE_DISABLE = "1"