blob: 5a3097e0a604294cd62013a16a15a04f0f5020e3 [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001require recipes-devtools/atp/atp-source_3.1.inc
2inherit package
3
4SUMMARY = "End-to-end tests evaluating ATP kernel modules service correctness"
5SECTION = "kernel/userland"
6
7S = "${WORKDIR}/git"
8SRC_URI = "${ATP_SRC}"
9
10EXTRA_OEMAKE += "-C linux/test"
11
12do_compile() {
13 oe_runmake
14}
15
16do_install() {
17 oe_runmake DESTDIR=${D} PREFIX=${prefix} install
18}
19
20DEPENDS = "atp-uapi cppunit"
21RDEPENDS:${PN} = "atp-uapi"