blob: 0cf6fd36bce9bd9037ce6d0e6923eefbe8ee25fe [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "JSON for modern C++"
2HOMEPAGE = "https://nlohmann.github.io/json/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588"
6
Andrew Geissler9aee5002022-03-30 16:27:02 +00007CVE_PRODUCT = "json-for-modern-cpp"
8
Andrew Geissler595f6302022-01-24 19:11:47 +00009SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1;protocol=https \
10 "
11
12SRCREV = "4f8fba14066156b73f1189a2b8bd568bde5284c5"
13
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
19
20# nlohmann-json is a header only C++ library, so the main package will be empty.
21
22RDEPENDS:${PN}-dev = ""
23
24BBCLASSEXTEND = "native nativesdk"
25
26# other packages commonly reference the file directly as "json.hpp"
27# create symlink to allow this usage
28do_install:append() {
29 ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
30}