blob: 7ee63b13326d5d6648c9a95e34d83564c9241e0f [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
19HOMEPAGE = "http://www.hboehm.info/gc/"
20SECTION = "devel"
21LICENSE = "MIT"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=7912d9213b3547f8a81aadd08893fe84"
23
24DEPENDS = "libatomic-ops"
25
26SRCREV = "47e9106c17b72e9ee5501308f69ea94531e798b3"
Andrew Geissler595f6302022-01-24 19:11:47 +000027SRC_URI = "git://github.com/ivmai/bdwgc.git;branch=master;protocol=https"
Andrew Geisslereff27472021-10-29 15:35:00 -050028
29S = "${WORKDIR}/git"
30
31inherit autotools pkgconfig
32
33EXTRA_OECONF += "--enable-cpluscplus"
34
35CFLAGS:append:libc-musl = " -D_GNU_SOURCE -DNO_GETCONTEXT -DSEARCH_FOR_DATA_START -DUSE_MMAP -DHAVE_DL_ITERATE_PHDR"
36
37FILES:${PN}-doc = "${datadir}"
38
39BBCLASSEXTEND = "native nativesdk"