blob: df441e8db22b797572e6a141ce5c4288fd0e1e60 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001DESCRIPTION = "the compiling PHP template engine"
2SECTION = "console/network"
3HOMEPAGE = "https://www.smarty.net/"
4
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "GPL-3.0-only"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LIC_FILES_CHKSUM = "file://LICENSE;md5=2c0f216b2120ffc367e20f2b56df51b3"
7
8DEPENDS += "php"
9
10SRC_URI = "git://github.com/smarty-php/smarty.git;protocol=https;branch=master"
11
Andrew Geissler78b72792022-06-14 06:47:25 -050012SRCREV = "71036be8be02bf93735c47b0b745f722efbc729f"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013
14S = "${WORKDIR}/git"
15
16do_install() {
17 install -d ${D}${datadir}/php/smarty3/libs/
18 install -m 0644 ${S}/libs/*.php ${D}${datadir}/php/smarty3/libs/
19
20 install -d ${D}${datadir}/php/smarty3/libs/plugins
21 install -m 0644 ${S}/libs/plugins/*.php ${D}${datadir}/php/smarty3/libs/plugins/
22
23 install -d ${D}${datadir}/php/smarty3/libs/sysplugins
24 install -m 0644 ${S}/libs/sysplugins/*.php ${D}${datadir}/php/smarty3/libs/sysplugins/
25}
26FILES:${PN} = "${datadir}/php/smarty3/"