blob: 528f99ef2055e7ffd9c4678a1bdb4674295a490b [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Protocol Buffers"
2HOMEPAGE = "https://developers.google.com/protocol-buffers/"
3SECTION = "devel/python"
4
5LICENSE = "BSD-3-Clause"
Patrick Williamsde0582f2022-04-08 10:23:27 -05006LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=53dbfa56f61b90215a9f8f0d527c043d"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007
8inherit pypi setuptools3
9
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050010SRC_URI[sha256sum] = "9130759e719bee1e6d05ca6a3037f7eff66d7a7ff6ba25871917dc40e8f3fbb6"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011
12# http://errors.yoctoproject.org/Errors/Details/184715/
13# Can't find required file: ../src/google/protobuf/descriptor.proto
14CLEANBROKEN = "1"
15
16UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/"
17
18DEPENDS += "protobuf"
19
20RDEPENDS:${PN} += " \
21 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-json \
23 ${PYTHON_PN}-logging \
24 ${PYTHON_PN}-netclient \
25 ${PYTHON_PN}-numbers \
26 ${PYTHON_PN}-pkgutil \
27 ${PYTHON_PN}-six \
28 ${PYTHON_PN}-unittest \
29"
30
31# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
32BBCLASSEXTEND = "native nativesdk"
33
34DISTUTILS_BUILD_ARGS += "--cpp_implementation"
35DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
36
37do_compile:prepend:class-native () {
38 export KOKORO_BUILD_NUMBER="1"
39}