blob: dacaaa787850aff2174c93747df927e651196091 [file] [log] [blame]
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05001SUMMARY = "Python interface for c-ares"
2DESCRIPTION = "\
3pycares is a Python module which provides an interface to c-ares. c-ares is \
4a C library that performs DNS requests and name resolutions asynchronously."
5HOMEPAGE = "https://github.com/saghul/pycares"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=b1538fcaea82ebf2313ed648b96c69b1"
8
9SRC_URI[md5sum] = "92fa9622ba42cb895d598910722e80b5"
10SRC_URI[sha256sum] = "735b4f75fd0f595c4e9184da18cd87737f46bc81a64ea41f4edce2b6b68d46d2"
11
12PYPI_PACKAGE = "pycares"
13
14inherit pypi setuptools3
15
16DEPENDS += "${PYTHON_PN}-cffi-native"
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-cffi \
20 ${PYTHON_PN}-idna \
21"