blob: 5172b0a05e0e2f24b53d3345dd2a349daab8507b [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "A toolkit to write, run and analyze benchmarks"
2DESCRIPTION = " \
3The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
4Features: \
5 * Simple API to run reliable benchmarks \
6 * Automatically calibrate a benchmark for a time budget. \
7 * Spawn multiple worker processes. \
8 * Compute the mean and standard deviation. \
9 * Detect if a benchmark result seems unstable. \
10 * JSON format to store benchmark results. \
11 * Support multiple units: seconds, bytes and integer. \
12"
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
15
16SRC_URI[sha256sum] = "8a85dd42e067131d5b26b71472336da7f7f4b87ff9c97350d89f5ff0de9adedc"
17
18DEPENDS += "${PYTHON_PN}-six-native"
19
20PYPI_PACKAGE = "pyperf"
21inherit pypi setuptools3
22
23RDEPENDS:${PN} += "${PYTHON_PN}-misc"