blob: 9b08f759a263d4f22d2663a8b61a844a4493ba82 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Yet Another Python Profiler"
2HOMEPAGE = "https://github.com/sumerc/yappi"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=71c208c9a4fd864385eb69ad4caa3bee"
6
Andrew Geissler78b72792022-06-14 06:47:25 -05007SRC_URI[sha256sum] = "f54c25f04aa7c613633b529bffd14e0699a4363f414dc9c065616fd52064a49b"
Andrew Geissler595f6302022-01-24 19:11:47 +00008
9SRC_URI += " \
10 file://run-ptest \
11 file://0001-Fix-imports-for-ptests.patch \
12"
13
14inherit pypi setuptools3 ptest
15
16RDEPENDS:${PN} += "\
17 ${PYTHON_PN}-datetime \
18 ${PYTHON_PN}-pickle \
19 ${PYTHON_PN}-threading \
20"
21
22RDEPENDS:${PN}-ptest += " \
23 ${PYTHON_PN}-gevent \
24 ${PYTHON_PN}-multiprocessing \
25 ${PYTHON_PN}-pytest \
26 ${PYTHON_PN}-profile \
27 ${PYTHON_PN}-zopeinterface \
28"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/tests
32 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
33 cp -f ${S}/yappi/yappi.py ${D}/${PTEST_PATH}/
34}