blob: 0867d1cb536869513562d988f355c49f96991f2b [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "The module provides handy URL class for url parsing and changing"
2HOMEPAGE = "https://github.com/aio-libs/yarl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e581798a7b985311f29fa3e163ea27ae"
5
6SRC_URI[sha256sum] = "45399b46d60c253327a460e99856752009fcee5f5d3c80b2f7c0cae1c38d56dd"
7
8SRC_URI += "file://run-ptest"
9
10PYPI_PACKAGE = "yarl"
11
12inherit pypi ptest setuptools3
13
14RDEPENDS:${PN} = "\
15 ${PYTHON_PN}-multidict \
16 ${PYTHON_PN}-idna \
17"
18
19RDEPENDS:${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}