blob: d0443d1ce64f7710c9a854a9bb69996f74e65e49 [file] [log] [blame]
Patrick Williamsf7326942020-04-08 10:26:49 -05001SUMMARY = "sdbus++ dbus API / binding generator"
2DESCRIPTION = "Generates bindings against sdbusplus for dbus APIs"
3
Patrick Williams751f8682022-03-03 09:32:32 -06004PYPI_PACKAGE = "sdbusplus"
5PV = "1.0"
Patrick Williams8564d352020-05-19 06:56:04 -05006inherit setuptools3
Patrick Williamsf7326942020-04-08 10:26:49 -05007
8include sdbusplus-rev.inc
9
Patrick Williams8564d352020-05-19 06:56:04 -050010## The sdbusplus repository has an Apache LICENSE file, which we would
11## normally check here, but the python setup script is in a subdirectory
12## which requires us to set ${S} below. When we change ${S} from the root
13## of the repository, bitbake can no longer find the LICENSE file. Point
14## to the common Apache license file in poky's meta instead.
15LICENSE = "Apache-2.0"
16LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
17
18S="${WORKDIR}/git/tools"
19
Patrick Williamsf7326942020-04-08 10:26:49 -050020DEPENDS += " \
Patrick Williamsf7326942020-04-08 10:26:49 -050021 ${PYTHON_PN}-inflection-native \
22 ${PYTHON_PN}-mako-native \
23 ${PYTHON_PN}-pyyaml-native \
24 "
25
Patrick Williams12fc9392021-08-06 09:16:53 -050026RDEPENDS:${PN} += " \
Patrick Williamsf7326942020-04-08 10:26:49 -050027 ${PYTHON_PN}-inflection \
28 ${PYTHON_PN}-mako \
29 ${PYTHON_PN}-pyyaml \
30 "
31
Patrick Williamsf7326942020-04-08 10:26:49 -050032BBCLASSEXTEND += "native nativesdk"