blob: 3ef6b35baae8ec21ccd6be6ebbc3ded0b002ae61 [file] [log] [blame]
Andrew Geissler5a43b432020-06-13 10:46:56 -05001# Allow checking of required and conflicting features
Brad Bishop6dbb3162019-11-25 09:41:34 -05002#
Andrew Geisslerd159c7f2021-09-02 21:05:58 -05003# xxx = [DISTRO,MACHINE,COMBINED,IMAGE]
Andrew Geissler5a43b432020-06-13 10:46:56 -05004#
5# ANY_OF_xxx_FEATURES: ensure at least one item on this list is included
6# in xxx_FEATURES.
7# REQUIRED_xxx_FEATURES: ensure every item on this list is included
8# in xxx_FEATURES.
9# CONFLICT_xxx_FEATURES: ensure no item in this list is included in
10# xxx_FEATURES.
Brad Bishop6dbb3162019-11-25 09:41:34 -050011#
12# Copyright 2019 (C) Texas Instruments Inc.
13# Copyright 2013 (C) O.S. Systems Software LTDA.
14
15python () {
Andrew Geissler82c905d2020-04-13 13:39:40 -050016 if d.getVar('PARSE_ALL_RECIPES', False):
17 return
18
Andrew Geissler5a43b432020-06-13 10:46:56 -050019 unused = True
Brad Bishop6dbb3162019-11-25 09:41:34 -050020
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050021 for kind in ['DISTRO', 'MACHINE', 'COMBINED', 'IMAGE']:
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000022 if d.getVar('ANY_OF_' + kind + '_FEATURES') is None and not d.hasOverrides('ANY_OF_' + kind + '_FEATURES') and \
23 d.getVar('REQUIRED_' + kind + '_FEATURES') is None and not d.hasOverrides('REQUIRED_' + kind + '_FEATURES') and \
24 d.getVar('CONFLICT_' + kind + '_FEATURES') is None and not d.hasOverrides('CONFLICT_' + kind + '_FEATURES'):
Andrew Geissler5a43b432020-06-13 10:46:56 -050025 continue
Brad Bishop6dbb3162019-11-25 09:41:34 -050026
Andrew Geissler5a43b432020-06-13 10:46:56 -050027 unused = False
Brad Bishop6dbb3162019-11-25 09:41:34 -050028
Andrew Geissler5a43b432020-06-13 10:46:56 -050029 # Assume at least one var is set.
30 features = set((d.getVar(kind + '_FEATURES') or '').split())
Brad Bishop6dbb3162019-11-25 09:41:34 -050031
Andrew Geissler5a43b432020-06-13 10:46:56 -050032 any_of_features = set((d.getVar('ANY_OF_' + kind + '_FEATURES') or '').split())
33 if any_of_features:
34 if set.isdisjoint(any_of_features, features):
35 raise bb.parse.SkipRecipe("one of '%s' needs to be in %s_FEATURES"
36 % (' '.join(any_of_features), kind))
Brad Bishop6dbb3162019-11-25 09:41:34 -050037
Andrew Geissler5a43b432020-06-13 10:46:56 -050038 required_features = set((d.getVar('REQUIRED_' + kind + '_FEATURES') or '').split())
39 if required_features:
40 missing = set.difference(required_features, features)
41 if missing:
42 raise bb.parse.SkipRecipe("missing required %s feature%s '%s' (not in %s_FEATURES)"
43 % (kind.lower(), 's' if len(missing) > 1 else '', ' '.join(missing), kind))
Brad Bishop6dbb3162019-11-25 09:41:34 -050044
Andrew Geissler5a43b432020-06-13 10:46:56 -050045 conflict_features = set((d.getVar('CONFLICT_' + kind + '_FEATURES') or '').split())
46 if conflict_features:
47 conflicts = set.intersection(conflict_features, features)
48 if conflicts:
49 raise bb.parse.SkipRecipe("conflicting %s feature%s '%s' (in %s_FEATURES)"
50 % (kind.lower(), 's' if len(conflicts) > 1 else '', ' '.join(conflicts), kind))
Brad Bishop6dbb3162019-11-25 09:41:34 -050051
Andrew Geissler5a43b432020-06-13 10:46:56 -050052 if unused:
53 bb.warn("Recipe inherits features_check but doesn't use it")
Brad Bishop6dbb3162019-11-25 09:41:34 -050054}