blob: 9b53dfba7abf7a210cf07f7f91a7762caff2b620 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Extract UUID from ${ROOTFS}, which must have been built
2# by the time that this function gets called. Only works
3# on ext file systems and depends on tune2fs.
4def get_rootfs_uuid(d):
5 import subprocess
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006 rootfs = d.getVar('ROOTFS')
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007 output = subprocess.check_output(['tune2fs', '-l', rootfs])
8 for line in output.split('\n'):
9 if line.startswith('Filesystem UUID:'):
10 uuid = line.split()[-1]
11 bb.note('UUID of %s: %s' % (rootfs, uuid))
12 return uuid
13 bb.fatal('Could not determine filesystem UUID of %s' % rootfs)
14
15# Replace the special <<uuid-of-rootfs>> inside a string (like the
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016# root= APPEND string in a syslinux.cfg or systemd-boot entry) with the
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017# actual UUID of the rootfs. Does nothing if the special string
18# is not used.
19def replace_rootfs_uuid(d, string):
20 UUID_PLACEHOLDER = '<<uuid-of-rootfs>>'
21 if UUID_PLACEHOLDER in string:
22 uuid = get_rootfs_uuid(d)
23 string = string.replace(UUID_PLACEHOLDER, uuid)
24 return string