blob: 3d1993576a071e1e789d795e4006fe43a5143f81 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001ROOTFS_BOOTSTRAP_INSTALL = ""
2IMAGE_TYPES_MASKED += "container"
Patrick Williams213cb262021-08-07 19:21:33 -05003IMAGE_TYPEDEP:container = "tar.bz2"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004
5python __anonymous() {
6 if "container" in d.getVar("IMAGE_FSTYPES") and \
7 d.getVar("IMAGE_CONTAINER_NO_DUMMY") != "1" and \
8 "linux-dummy" not in d.getVar("PREFERRED_PROVIDER_virtual/kernel"):
9 msg = '"container" is in IMAGE_FSTYPES, but ' \
10 'PREFERRED_PROVIDER_virtual/kernel is not "linux-dummy". ' \
11 'Unless a particular kernel is needed, using linux-dummy will ' \
12 'prevent a kernel from being built, which can reduce ' \
13 'build times. If you don\'t want to use "linux-dummy", set ' \
14 '"IMAGE_CONTAINER_NO_DUMMY" to "1".'
15
16 # Raising skip recipe was Paul's clever idea. It causes the error to
17 # only be shown for the recipes actually requested to build, rather
18 # than bb.fatal which would appear for all recipes inheriting the
19 # class.
20 raise bb.parse.SkipRecipe(msg)
21}