blob: 27bd69ff33bfc78953d8799142e9b233e507817f [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001inherit kernel-arch
2
Brad Bishop316dfdd2018-06-25 12:45:53 -04003# We do the dependency this way because the output is not preserved
4# in sstate, so we must force do_compile to run (once).
5do_configure[depends] += "make-mod-scripts:do_compile"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006
7export OS = "${TARGET_OS}"
8export CROSS_COMPILE = "${TARGET_PREFIX}"
9
10# This points to the build artefacts from the main kernel build
11# such as .config and System.map
12# Confusingly it is not the module build output (which is ${B}) but
13# we didn't pick the name.
14export KBUILD_OUTPUT = "${STAGING_KERNEL_BUILDDIR}"
15
Brad Bishop316dfdd2018-06-25 12:45:53 -040016export KERNEL_VERSION = "${@oe.utils.read_file('${STAGING_KERNEL_BUILDDIR}/kernel-abiversion')}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017KERNEL_OBJECT_SUFFIX = ".ko"
18
19# kernel modules are generally machine specific
20PACKAGE_ARCH = "${MACHINE_ARCH}"
21