blob: 10cc3a06457bbf4c86c0c90b5ff2db0958a5f5c9 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001#
2# This class helps make sure that Python extensions built with PyO3
3# and setuptools_rust properly set up the environment for cross compilation
4#
5
6inherit cargo python3-dir siteinfo
7
8export PYO3_CROSS="1"
9export PYO3_CROSS_PYTHON_VERSION="${PYTHON_BASEVERSION}"
10export PYO3_CROSS_LIB_DIR="${STAGING_LIBDIR}"
11export CARGO_BUILD_TARGET="${HOST_SYS}"
12export RUSTFLAGS
13export PYO3_PYTHON="${PYTHON}"
14export PYO3_CONFIG_FILE="${WORKDIR}/pyo3.config"
15
16python_pyo3_do_configure () {
17 cat > ${WORKDIR}/pyo3.config << EOF
18implementation=CPython
19version=${PYTHON_BASEVERSION}
20shared=true
21abi3=false
22lib_name=${PYTHON_DIR}
23lib_dir=${STAGING_LIBDIR}
24pointer_width=${SITEINFO_BITS}
25build_flags=WITH_THREAD
26suppress_build_script_link_lines=false
27EOF
28}
29
30EXPORT_FUNCTIONS do_configure