blob: 806833bc7d0e7d7e69a55ac4d4ae86cf5c19beca [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Embedded Linux Library"
2HOMEPAGE = "https://01.org/ell"
3DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
4low-level functionality for system daemons. It typically has no \
5dependencies other than the Linux kernel, C standard library, and \
6libdl (for dynamic linking). While ELL is designed to be efficient \
7and compact enough for use on embedded Linux platforms, it is not \
8limited to resource-constrained systems."
9SECTION = "libs"
10LICENSE = "LGPL-2.1-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
12
13DEPENDS = "dbus"
14
15inherit autotools pkgconfig
16
17SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz \
Andrew Geissler615f2f12022-07-15 14:00:58 -050018 file://0001-build-fix-time.h-related-breakage-on-musl.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000019 "
Andrew Geissler615f2f12022-07-15 14:00:58 -050020SRC_URI[sha256sum] = "ba86cfa4aaf10151443edd63a7687914465d969f5dda00a2c1fcb11bd85e417f"
Andrew Geissler9aee5002022-03-30 16:27:02 +000021
22do_configure:prepend () {
23 mkdir -p ${S}/build-aux
24}