blob: b7b54e9ccc55d242ac10fe9c7ca0132c963a8d43 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Cross locale generation tool for glibc"
2HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3SECTION = "libs"
4LICENSE = "LGPL-2.1-only"
5
6LIC_FILES_CHKSUM = "file://LICENSES;md5=1541fd8f5e8f1579512bf05f533371ba \
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11require glibc-version.inc
12
13# Tell autotools that we're working in the localedef directory
14#
15AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
16
17inherit autotools
18inherit native
19
20FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
21
22SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
23 git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef;protocol=https \
24 \
25 file://0001-localedef-Add-hardlink-resolver-from-util-linux.patch \
26 file://0002-localedef-fix-ups-hardlink-to-make-it-compile.patch \
27 \
28 file://0010-eglibc-Cross-building-and-testing-instructions.patch \
29 file://0011-eglibc-Help-bootstrap-cross-toolchain.patch \
30 file://0012-eglibc-Resolve-__fpscr_values-on-SH4.patch \
31 file://0013-eglibc-Forward-port-cross-locale-generation-support.patch \
32 file://0014-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
33 file://0021-Replace-echo-with-printf-builtin-in-nscd-init-script.patch \
34 file://0023-timezone-Make-shell-interpreter-overridable-in-tzsel.patch \
35 "
36# Makes for a rather long rev (22 characters), but...
37#
38SRCREV_FORMAT = "glibc_localedef"
39
40S = "${WORKDIR}/git"
41
42EXTRA_OECONF = "--with-glibc=${S}"
43
44# We do not need bash to run tzselect script, the default is to use
45# bash but it can be configured by setting KSHELL Makefile variable
46EXTRA_OEMAKE += "KSHELL=/bin/sh"
47
48CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
49
50do_install() {
51 install -d ${D}${bindir}
52 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
53 install -m 0755 ${B}/cross-localedef-hardlink ${D}${bindir}/cross-localedef-hardlink
54}