blob: 0d6471ddbcb63e2f9e2cbb5a5be0f49149f7c284 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPL-3.0-or-later"
Andrew Geissler78b72792022-06-14 06:47:25 -050010LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=7a19377a02749d8a1281ed608169b0ee"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011
12DEPENDS = "zstd"
13
Andrew Geissler78b72792022-06-14 06:47:25 -050014SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz \
15 file://0001-xxhash.h-Fix-build-with-gcc-12.patch \
16"
17SRC_URI[sha256sum] = "59b28a57c3a45e48d6049001999c9f94cd4d3e9b0196994bed9a6a7437ffa3bc"
Andrew Geissler9aee5002022-03-30 16:27:02 +000018
19UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
20
21inherit cmake
22
23PATCHTOOL = "patch"
24
25BBCLASSEXTEND = "native nativesdk"
26
27PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc"
28PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis"