blob: 4e6da70e4a5644c3ffeeb4bd47755df7dcd0f0d1 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "System Log Daemons"
2DESCRIPTION = "The sysklogd package implements system log daemons: syslogd"
3HOMEPAGE = "http://www.infodrom.org/projects/sysklogd/"
4SECTION = "base"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=5b4be4b2549338526758ef479c040943 \
8 file://src/syslogd.c;beginline=2;endline=15;md5=a880fecbc04503f071c494a9c0dd4f97 \
9 "
10
11inherit update-rc.d update-alternatives systemd autotools
12
Andrew Geissler9aee5002022-03-30 16:27:02 +000013SRC_URI = "git://github.com/troglobit/sysklogd.git;branch=master;protocol=https \
Andrew Geissler595f6302022-01-24 19:11:47 +000014 file://sysklogd \
15 "
16
Andrew Geissler78b72792022-06-14 06:47:25 -050017SRCREV = "7dc4783af8e8e0d200d38a87b6a4bc9bbec5ce92"
Andrew Geissler595f6302022-01-24 19:11:47 +000018
19S = "${WORKDIR}/git"
20
21EXTRA_OECONF = "--with-systemd=${systemd_system_unitdir} --without-logger"
22
23do_install:append () {
24 install -d ${D}${sysconfdir}
25 install -m 644 ${S}/syslog.conf ${D}${sysconfdir}/syslog.conf
26 install -d ${D}${sysconfdir}/init.d
27 install -m 755 ${WORKDIR}/sysklogd ${D}${sysconfdir}/init.d/syslog
28}
29
30SYSTEMD_PACKAGES = "${PN}"
31SYSTEMD_SERVICE:${PN} = "syslogd.service"
32SYSTEMD_AUTO_ENABLE = "enable"
33
34INITSCRIPT_NAME = "syslog"
35CONFFILES:${PN} = "${sysconfdir}/syslog.conf"
36RCONFLICTS:${PN} = "rsyslog busybox-syslog syslog-ng"
37
38FILES:${PN} += "${@bb.utils.contains('DISTRO_FEATURES','systemd','${exec_prefix}/lib/tmpfiles.d/sysklogd.conf', '', d)}"
39
40ALTERNATIVE_PRIORITY = "100"
41
42ALTERNATIVE:${PN}-doc = "syslogd.8"
43ALTERNATIVE_LINK_NAME[syslogd.8] = "${mandir}/man8/syslogd.8"
44
45pkg_prerm:${PN} () {
46 if test "x$D" = "x"; then
47 if test "$1" = "upgrade" -o "$1" = "remove"; then
48 /etc/init.d/syslog stop || :
49 fi
50 fi
51}
52
53python () {
54 if not bb.utils.contains('DISTRO_FEATURES', 'sysvinit', True, False, d):
55 d.setVar("INHIBIT_UPDATERCD_BBCLASS", "1")
56}