blob: 66763349d2c5eb05afda1523e4d8d33e5dcb5c97 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Userspace RCU (read-copy-update) library"
2DESCRIPTION = "A userspace RCU (read-copy-update) library. This data \
3synchronization library provides read-side access which scales linearly \
4with the number of cores. "
5HOMEPAGE = "http://lttng.org/urcu"
6BUGTRACKER = "http://lttng.org/project/issues"
7
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "LGPL-2.1-or-later & MIT"
Andrew Geissler595f6302022-01-24 19:11:47 +00009LIC_FILES_CHKSUM = "file://LICENSE;md5=e548d28737289d75a8f1e01ba2fd7825 \
10 file://include/urcu/urcu.h;beginline=4;endline=32;md5=4de0d68d3a997643715036d2209ae1d9 \
11 file://include/urcu/uatomic/x86.h;beginline=4;endline=21;md5=58e50bbd8a2f073bb5500e6554af0d0b"
12
13SRC_URI = "http://lttng.org/files/urcu/userspace-rcu-${PV}.tar.bz2"
14
15SRC_URI[sha256sum] = "3213f33d2b8f710eb920eb1abb279ec04bf8ae6361f44f2513c28c20d3363083"
16
17S = "${WORKDIR}/userspace-rcu-${PV}"
18inherit autotools multilib_header
19
20CPPFLAGS:append:riscv64 = " -pthread -D_REENTRANT"
21
22do_install:append() {
23 oe_multilib_header urcu/config.h
24}