blob: 5befec8d6b293da3d9935383fa16037e2d0bd58a [file] [log] [blame]
George Hung4a9a9602020-07-09 21:19:29 +08001SUMMARY = "OpenBMC Quanta Detect Fan Fail Service"
2DESCRIPTION = "OpenBMC Quanta Detect Fan Fail Daemon."
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS_${PN} += "bash"
11
12SRC_URI = " file://gbs-detect-fan-fail.sh \
13 file://gbs-detect-fan-fail.service \
14 "
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m 0755 ${WORKDIR}/gbs-detect-fan-fail.sh ${D}${bindir}/
19
20 install -d ${D}${systemd_system_unitdir}
21 install -m 0644 ${WORKDIR}/gbs-detect-fan-fail.service ${D}${systemd_system_unitdir}
22}
23
24SYSTEMD_PACKAGES = "${PN}"
25SYSTEMD_SERVICE_${PN} = "gbs-detect-fan-fail.service"