blob: 19885a58c74ea74fd2e48053551b9f9031b1514d [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=5279a7ab369ba336989dcf2a107e5c8e"
10
11PYPI_PACKAGE = "GitPython"
12
13inherit pypi python_setuptools_build_meta
14
Patrick Williams39653562024-03-01 08:54:02 -060015SRC_URI[sha256sum] = "2d99869e0fef71a73cbd242528105af1d6c1b108c60dfabd994bf292f76c3ceb"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060016
Patrick Williams73bd93f2024-02-20 08:07:48 -060017DEPENDS += " python3-gitdb"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060018
19RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060020 python3-datetime \
21 python3-gitdb \
22 python3-io \
23 python3-logging \
24 python3-math \
25 python3-netclient \
26 python3-stringold \
27 python3-unittest \
28 python3-unixadmin \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060029 git \
30"
31
32BBCLASSEXTEND = "native nativesdk"