blob: 76acc4ae27e9b113b5300350ca7a28798a0469cb [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001SUMMARY = "Plugin and hook calling mechanisms for python"
2HOMEPAGE = "https://github.com/pytest-dev/pluggy"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2"
5
Patrick Williams73bd93f2024-02-20 08:07:48 -06006SRC_URI[sha256sum] = "8c85c2876142a764e5b7548e7d9a0e0ddb46f5185161049a79b7e974454223be"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06007
Patrick Williams73bd93f2024-02-20 08:07:48 -06008DEPENDS += "python3-setuptools-scm-native"
9RDEPENDS:${PN} += "python3-importlib-metadata \
10 python3-more-itertools \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060011"
12
Andrew Geissler9aee5002022-03-30 16:27:02 +000013inherit pypi ptest python_setuptools_build_meta
Andrew Geissler6ce62a22020-11-30 19:58:47 -060014
15SRC_URI += " \
16 file://run-ptest \
17"
18
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060020 python3-pytest \
21 python3-unittest-automake-output \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060022"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/testing
26 cp -rf ${S}/testing/* ${D}${PTEST_PATH}/testing/
27}
Andrew Geissler78b72792022-06-14 06:47:25 -050028
29BBCLASSEXTEND = "native nativesdk"