blob: cea2a971d338d1d072c2be9e095a402aa2f9c8e4 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Simple Python module for working with HTML/CSS color definitions."
2HOMEPAGE = "https://pypi.org/project/webcolors/"
3LICENSE = "BSD-3-Clause"
Patrick Williamsb542dec2023-06-09 01:26:37 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=702b1ef12cf66832a88f24c8f2ee9c19"
Andrew Geissler595f6302022-01-24 19:11:47 +00005
Patrick Williamsb542dec2023-06-09 01:26:37 -05006SRC_URI[sha256sum] = "c225b674c83fa923be93d235330ce0300373d02885cef23238813b0d5668304a"
Andrew Geissler595f6302022-01-24 19:11:47 +00007
Patrick Williamsb542dec2023-06-09 01:26:37 -05008inherit pypi python_setuptools_build_meta ptest
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10RDEPENDS:${PN}:class-target = "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060011 python3-stringold \
Andrew Geissler595f6302022-01-24 19:11:47 +000012"
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 python3-pytest \
20 python3-unittest-automake-output \
Andrew Geissler595f6302022-01-24 19:11:47 +000021"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28BBCLASSEXTEND = "native nativesdk"