blob: e3fd67172895d663c2d76e6ad6350ada1d9ab832 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Grilo is a framework forsearching media content from various sources"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4
5DEPENDS = " \
6 libxml2 \
7 glib-2.0 \
8"
9
10GNOMEBASEBUILDCLASS = "meson"
11
12inherit gnomebase gobject-introspection gtk-doc gettext vala
13
14SRC_URI[archive.md5sum] = "f02bf585d1a48dc65be8b90ae3b08330"
15SRC_URI[archive.sha256sum] = "7e44b2e74c31ed24eb97e43265a9e41effe8660287b02295111805c7bda7f1e8"
16
17GIR_MESON_OPTION = "enable-introspection"
18GTKDOC_MESON_OPTION = "enable-gtk-doc"
19
20# Note: removing 'net' from PACKAGECONFIG causes
21# | bindings/vala/meson.build:15:0: ERROR: Unknown variable "grlnet_gir".
22PACKAGECONFIG ??= "net"
23
24PACKAGECONFIG[net] = "-Denable-grl-net=true, -Denable-grl-net=false, libsoup-2.4"
25PACKAGECONFIG[test-ui] = "-Denable-test-ui=true, -Denable-test-ui=false, gtk+3 liboauth"
26
27# Once we have a recipe for 'totem-plparser' this can turn into a PACKAGECONFIG
28EXTRA_OEMESON = "-Denable-grl-pls=false"
29