blob: a88410f2ff8126cd12a456d6ff36552f436be68c [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "JSON C++ lib used to read and write json file."
2DESCRIPTION = "Jsoncpp is an implementation of a JSON (http://json.org) reader \
3 and writer in C++. JSON (JavaScript Object Notation) is a \
4 lightweight data-interchange format. It is easy for humans to \
5 read and write. It is easy for machines to parse and generate."
6
7HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp"
8
9SECTION = "libs"
10
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=fa2a23dd1dc6c139f35105379d76df2b"
13
Brad Bishope42b3e32020-01-15 22:08:42 -050014SRCREV = "d2e6a971f4544c55b8e3b25cf96db266971b778f"
Brad Bishop316dfdd2018-06-25 12:45:53 -040015SRC_URI = "git://github.com/open-source-parsers/jsoncpp"
16
17S = "${WORKDIR}/git"
18
19inherit cmake
20
21EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON -DJSONCPP_WITH_TESTS=OFF"
Brad Bishopc342db32019-05-15 21:57:59 -040022
23BBCLASSEXTEND = "native"