Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Text::CharWidth - Get number of occupied columns of a string on terminal." |
| 2 | DESCRIPTION = "This module supplies features similar as wcwidth(3) and wcswidth(3) \ |
| 3 | in C language. \ |
| 4 | Characters have its own width on terminal depending on locale. For \ |
| 5 | example, ASCII characters occupy one column per character, east Asian \ |
| 6 | fullwidth characters (like Hiragana or Han Ideograph) occupy two columns \ |
| 7 | per character, and combining characters (apperaring in ISO-8859-11 Thai, \ |
| 8 | Unicode, and so on) occupy zero columns per character. mbwidth() gives the \ |
| 9 | width of the first character of the given string and mbswidth() gives the \ |
| 10 | width of the whole given string." |
| 11 | SECTION = "libs" |
| 12 | |
| 13 | HOMEPAGE = "http://search.cpan.org/~kubota/Text-CharWidth-${PV}/" |
| 14 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 15 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 16 | LIC_FILES_CHKSUM = "file://README;md5=d8d54c8c500cbdd57a4c15911d9d96db" |
| 17 | |
| 18 | SRC_URI = "${CPAN_MIRROR}/authors/id/K/KU/KUBOTA/Text-CharWidth-${PV}.tar.gz" |
| 19 | |
| 20 | SRC_URI[md5sum] = "37a723df0580c0758c0ee67b37336c15" |
| 21 | SRC_URI[sha256sum] = "abded5f4fdd9338e89fd2f1d8271c44989dae5bf50aece41b6179d8e230704f8" |
| 22 | |
| 23 | S = "${WORKDIR}/Text-CharWidth-${PV}" |
| 24 | |
| 25 | inherit cpan |
| 26 | |
| 27 | BBCLASSEXTEND = "native" |