blob: 44dab1d8a64979e42b0a018a0671f6637a02875b [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04002DESCRIPTION = "Software package manager that installs, updates, and removes \
3packages on RPM-based Linux distributions. It automatically computes \
4dependencies and determines the actions required to install packages."
Brad Bishopc342db32019-05-15 21:57:59 -04005LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://PACKAGE-LICENSING;md5=4a0548e303dbc77f067335b4d688e745 \
8 "
9
10SRC_URI = "git://github.com/rpm-software-management/dnf.git \
11 file://0001-Corretly-install-tmpfiles.d-configuration.patch \
12 file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \
13 file://0005-Do-not-prepend-installroot-to-logdir.patch \
14 file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
15 file://0030-Run-python-scripts-using-env.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050016 file://0001-set-python-path-for-completion_helper.patch \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050017 file://0001-dnf-write-the-log-lock-to-root.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040018 "
19
Andrew Geissler4b740dc2020-05-05 08:54:39 -050020SRCREV = "864c381baabf024c299dca75abfda96139b8f583"
Brad Bishopc342db32019-05-15 21:57:59 -040021UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
22
23S = "${WORKDIR}/git"
24
25inherit cmake gettext bash-completion distutils3-base systemd
26
27DEPENDS += "libdnf librepo libcomps python3-iniparse"
28
29# manpages generation requires http://www.sphinx-doc.org/
30EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
31
32BBCLASSEXTEND = "native nativesdk"
33
34RDEPENDS_${PN} += " \
35 python3-core \
36 python3-codecs \
37 python3-netclient \
38 python3-email \
39 python3-threading \
40 python3-distutils \
41 python3-logging \
42 python3-fcntl \
43 librepo \
44 python3-shell \
45 libcomps \
46 libdnf \
47 python3-sqlite3 \
48 python3-compression \
49 python3-rpm \
50 python3-iniparse \
51 python3-json \
52 python3-curses \
53 python3-misc \
54 python3-gpg \
55 "
56
57RDEPENDS_${PN}_class-native = ""
58
59RRECOMMENDS_${PN}_class-target += "gnupg"
60
61# Create a symlink called 'dnf' as 'make install' does not do it, but
62# .spec file in dnf source tree does (and then Fedora and dnf documentation
63# says that dnf binary is plain 'dnf').
64do_install_append() {
65 lnr ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf
66 lnr ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic
67}
68
69# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in
70do_install_append_class-native() {
71 create_wrapper ${D}/${bindir}/dnf \
72 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
73 RPM_NO_CHROOT_FOR_SCRIPTS=1
74}
75
76do_install_append_class-nativesdk() {
77 create_wrapper ${D}/${bindir}/dnf \
78 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
Brad Bishopf3f93bb2019-10-16 14:33:32 -040079 RPM_NO_CHROOT_FOR_SCRIPTS=1
Brad Bishopc342db32019-05-15 21:57:59 -040080}
81
82SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
83 dnf-automatic.service dnf-automatic.timer \
84 dnf-automatic-download.service dnf-automatic-download.timer \
85 dnf-automatic-install.service dnf-automatic-install.timer \
86 dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \
87"
88SYSTEMD_AUTO_ENABLE ?= "disable"
Andrew Geissler82c905d2020-04-13 13:39:40 -050089
90PNBLACKLIST[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"