blob: c7850f03ca97c743fc1e590bdd1893081d70b089 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Utility for modifying GPT disk partitioning"
2DESCRIPTION = "GPT fdisk is a disk partitioning tool loosely modeled on Linux fdisk, but used for modifying GUID Partition Table (GPT) disks. The related FixParts utility fixes some common problems on Master Boot Record (MBR) disks."
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
6
7DEPENDS = "util-linux"
8
Andrew Geissler4b740dc2020-05-05 08:54:39 -05009SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz \
10 file://0001-gptcurses-correctly-include-curses.h.patch \
11 "
12SRC_URI[md5sum] = "58dac67c85e46ca87b587231549aefe6"
13SRC_URI[sha256sum] = "0e7d3987cd0488ecaf4b48761bc97f40b1dc089e5ff53c4b37abe30bc67dcb2f"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
15UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/gptfdisk/files/gptfdisk/"
16UPSTREAM_CHECK_REGEX = "/gptfdisk/(?P<pver>(\d+[\.\-_]*)+)/"
17
18EXTRA_OEMAKE = "'CC=${CC}' 'CXX=${CXX}' gdisk fixparts ${PACKAGECONFIG_CONFARGS}"
19
20PACKAGECONFIG ??= "ncurses popt"
21PACKAGECONFIG[ncurses] = "cgdisk,,ncurses"
22PACKAGECONFIG[popt] = "sgdisk,,popt"
23
24do_install() {
25 install -d ${D}${sbindir}
26 for f in cgdisk sgdisk; do
27 if [ -x $f ]; then
28 install -m 0755 $f ${D}${sbindir}
29 fi
30 done
31 install -m 0755 gdisk ${D}${sbindir}
32 install -m 0755 fixparts ${D}${sbindir}
33}
34
35BBCLASSEXTEND = "native nativesdk"