blob: 598b5847873465c3140ca26d727f831494c28b98 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Keyboard configuration database for X Window"
2
3DESCRIPTION = "The non-arch keyboard configuration database for X \
4Window. The goal is to provide the consistent, well-structured, \
5frequently released open source of X keyboard configuration data for X \
6Window System implementations. The project is targeted to XKB-based \
7systems."
8
9HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
10BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
11
12LICENSE = "MIT & MIT-style"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
14
Andrew Geissler4b740dc2020-05-05 08:54:39 -050015SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2 \
16 file://0001-fix-python3-support.patch \
17 "
18SRC_URI[md5sum] = "b5980bdc6c7d79f6dcccba8c76bb6c5d"
19SRC_URI[sha256sum] = "1d4175278bf06000683656763a8b1d3282c61a314b6db41260c8efe92d621802"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21SECTION = "x11/libs"
22DEPENDS = "util-macros libxslt-native"
23
24EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
25
26FILES_${PN} += "${datadir}/X11/xkb"
27
28inherit autotools pkgconfig gettext
29
30do_install_append () {
31 install -d ${D}${datadir}/X11/xkb/compiled
32 cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
33}