blob: baf72f8e757951c2d8e6716500348a40ee089f32 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=2e9fb35867314fe31c6a4977ef7dd531"
7
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
9 file://0001-replace-krb5-config-with-pkg-config.patch \
10"
11
Andrew Geissler4b740dc2020-05-05 08:54:39 -050012SRC_URI[md5sum] = "db69aa37476dfdf9abaa2fb01b8bbf1a"
13SRC_URI[sha256sum] = "a50bfe62ad67a24f8b12dd7fd655ac43a0f0299f86ec45b11354f25fbb5829d0"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15CVE_PRODUCT = "curl libcurl"
16inherit autotools pkgconfig binconfig multilib_header
17
18PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} gnutls libidn proxy threaded-resolver verbose zlib"
19PACKAGECONFIG_class-native = "ipv6 proxy ssl threaded-resolver verbose zlib"
20PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl threaded-resolver verbose zlib"
21
22# 'ares' and 'threaded-resolver' are mutually exclusive
23PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares,,,threaded-resolver"
24PACKAGECONFIG[brotli] = "--with-brotli,--without-brotli,brotli"
25PACKAGECONFIG[builtinmanual] = "--enable-manual,--disable-manual"
26PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
27PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
28PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
29PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
30PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
31PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
32PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
33PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
34PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2"
35PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
36PACKAGECONFIG[mbedtls] = "--with-mbedtls=${STAGING_DIR_TARGET},--without-mbedtls,mbedtls"
Andrew Geissler4b740dc2020-05-05 08:54:39 -050037PACKAGECONFIG[mqtt] = "--enable-mqtt,--disable-mqtt,"
Andrew Geissler82c905d2020-04-13 13:39:40 -050038PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
39PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
40PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"
41PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
42PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp,"
43PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
44PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp,"
45PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
46PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss"
47PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
48PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
49PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver,,,,ares"
50PACKAGECONFIG[verbose] = "--enable-verbose,--disable-verbose"
51PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
52
53EXTRA_OECONF = " \
54 --disable-libcurl-option \
55 --disable-ntlm-wb \
56 --enable-crypto-auth \
57 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
58 --without-libmetalink \
59 --without-libpsl \
60"
61
62do_install_append_class-target() {
63 # cleanup buildpaths from curl-config
64 sed -i \
65 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
66 -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \
67 -e 's|${DEBUG_PREFIX_MAP}||g' \
68 ${D}${bindir}/curl-config
69}
70
71PACKAGES =+ "lib${BPN}"
72
73FILES_lib${BPN} = "${libdir}/lib*.so.*"
74RRECOMMENDS_lib${BPN} += "ca-certificates"
75
76FILES_${PN} += "${datadir}/zsh"
77
78inherit multilib_script
79MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/curl-config"
80
81BBCLASSEXTEND = "native nativesdk"