blob: 03a10ce62cbca637532dd8edc5d9a39264107007 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
6LICENSE = "GPLv2.0+"
7SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=bdfdd4986a0853eb84eeba85f9d0c4d6"
10
11DEPENDS = "glib-2.0 dbus json-glib libsoup-2.4 intltool-native"
12
13inherit meson pkgconfig gtk-doc gobject-introspection vala
14
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050015SRC_URI = "https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/${PV}/geoclue-${PV}.tar"
Brad Bishop15ae2502019-06-18 21:44:24 -040016
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050017SRC_URI[sha256sum] = "76494f1262fd90faea05116aface7f580b9b50f7c525bc86ccf33409cea95e8d"
Brad Bishop15ae2502019-06-18 21:44:24 -040018
19# Without this line, package is declared a library and named libgeoclue*
20AUTO_LIBNAME_PKGS = ""
21
22PACKAGECONFIG ??= "3g modem-gps cdma nmea lib"
23PACKAGECONFIG[3g] = "-D3g-source=true,-D3g-source=false,modemmanager"
24PACKAGECONFIG[modem-gps] = "-Dmodem-gps-source=true,-Dmodem-gps-source=false,modemmanager"
25PACKAGECONFIG[cdma] = "-Dcdma-source=true,-Dcdma-source=false,modemmanager"
Andrew Geissler89770b02020-06-13 10:40:47 -050026PACKAGECONFIG[nmea] = "-Dnmea-source=true,-Dnmea-source=false,avahi,avahi-daemon"
Brad Bishop15ae2502019-06-18 21:44:24 -040027PACKAGECONFIG[lib] = "-Dlibgeoclue=true,-Dlibgeoclue=false,gobject-introspection"
28
29GTKDOC_MESON_OPTION = "gtk-doc"
30
31EXTRA_OEMESON += " \
32 -Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \
33 -Ddemo-agent=false \
34"
35
36FILES_${PN} += " \
37 ${datadir}/dbus-1/system-services \
38 ${libdir} \
39 ${systemd_unitdir} \
40 ${prefix}/libexec \
41"
42
43FILES_${PN}-dev += " \
44 ${datadir}/dbus-1/interfaces \
45 ${datadir}/gir-1.0 \
46"