blob: 596186651538bcd4f9c8078ce2d38ee6933f0806 [file] [log] [blame]
Andrew Geissler4b7c1152020-11-30 19:55:29 -06001SUMMARY = "Web-based Traffic and Security Network Traffic Monitoring"
2DESCRIPTION = "ntopng is a web-based network traffic monitoring application \
3released under GPLv3. It is the new incarnation of the original \
4ntop written in 1998, and now revamped in terms of performance, \
5usability, and features."
6
7SECTION = "console/network"
8
9DEPENDS = "curl libmaxminddb libpcap lua mariadb ndpi json-c rrdtool zeromq"
10RDEPENDS_${PN} = "bash redis"
11LICENSE = "GPLv3"
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
13
14SRCREV = "5e649a2d1130b4a3ab0c5bb673d615172cc0bdbb"
15SRC_URI = "git://github.com/ntop/ntopng.git;protocol=git;branch=4.2-stable \
16 file://0001-configure.seed-fix-configure-error.patch \
17 file://0001-configure.seed-fix-host-contamination.patch \
18 file://0001-Makefile.in-don-t-use-the-internal-lua.patch \
19 file://0001-autogen.sh-generate-configure.ac-only.patch \
20 file://0001-configure.seed-not-check-clang-on-host.patch \
21 file://ntopng.service \
22"
23
24S = "${WORKDIR}/git"
25
26# don't use the lua under thirdparty as it supports cross compiling badly
27export LUA_LIB = "${STAGING_LIBDIR}/liblua.a"
28
29LDFLAGS_append_mipsarch = " -latomic"
30LDFLAGS_append_powerpc = " -latomic"
31LDFLAGS_append_riscv32 = " -latomic"
32inherit autotools-brokensep gettext systemd
33
34do_install_append() {
35 install -d ${D}${systemd_unitdir}/system/
36 install -m 0644 ${WORKDIR}/ntopng.service ${D}${systemd_unitdir}/system
37}
38
39FILES_${PN} += "\
40 ${systemd_unitdir}/system/ntopng.service"
41
42FILES_${PN}-doc += "\
43 /usr/man/man8/ntopng.8"
44
45do_configure_prepend() {
46 ${S}/autogen.sh
47}
48
49SYSTEMD_SERVICE_${PN} = "ntopng.service"