blob: 472b72fc2e6b0270ebc74599992c46ff5941f848 [file] [log] [blame]
Andrew Geissler4b7c1152020-11-30 19:55:29 -06001DESCRIPTION = "Modern C++ network programming libraries."
2
3# This library provides general purpose network functionality such as
4# socket communication to agent libraries. It was designed to be merged
5# into boost at some point and follows similar header library approach
6# for most functionality.
7
8SECTION = "libs"
9LICENSE = "BSL-1.0 & MIT & Python-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
11
12SRC_URI = "\
13 git://github.com/cpp-netlib/cpp-netlib.git;protocol=https;branch=0.13-release \
14"
15SRC_URI[sha256sum] = "0b9255bb0668d89867a1f367d770f12d7038db4f5b6111774ef032f669cccad4"
16
17SRCREV = "ca95f04d140acf619892ee02a82e930dd91ff7d4"
18
19S = "${WORKDIR}/git"
20
21inherit cmake pkgconfig
22
23DEPENDS = "zlib boost openssl"
24
25EXTRA_OECMAKE_append = " -DCPP-NETLIB_BUILD_TESTS=OFF -DCPP-NETLIB_BUILD_EXAMPLES=OFF"
26