blob: 7045f704736eb597d34dcfd2f2e96654d124d20a [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Machine-readable files for the SPIR-V Registry"
2SECTION = "graphics"
3HOMEPAGE = "https://www.khronos.org/registry/spir-v"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c938b85bceb8fb26c1a807f28a52ae2d"
6
7SRCREV = "e867c06631767a2d96424cbec530f9ee5e78180f"
8SRC_URI = "git://github.com/KhronosGroup/SPIRV-Headers;protocol=https;branch=main"
9PE = "1"
10# These recipes need to be updated in lockstep with each other:
11# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
12# vulkan-validation-layers, vulkan-utility-libraries.
13# The tags versions should always be sdk-x.y.z, as this is what
14# upstream considers a release.
15UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
16S = "${WORKDIR}/git"
17
18inherit cmake
19
20BBCLASSEXTEND = "native nativesdk"